This was caused by our nginx reverse proxy caching the endpoint which didn’t specify a Cache-Control header. Fixed by specifying Cache-Control on all beacon responses on the V2 relays.
Posted Dec 04, 2024 - 18:24 UTC
Resolved
This incident has been resolved.
Posted Dec 04, 2024 - 18:22 UTC
Investigating
We're investigating an issue where the `/latest` endpoint is sometimes returning a cached older round. Rounds can still be consistently retrieved by their round number directly, e.g. `GET https://api.drand.sh/v2/beacons/quicknet/rounds/1234/`